Sunday, 24 October, 2010

no service found for - "com.nokia.qt.mediaplayer"

Of late, I was trying to build QtMobility on Ubuntu, specifically experimenting with QtMultimedia feature set.

In the process, I stumbled on this (not so) strange issue which frustrated me for a log time. I was using Qt4.7 + QtMobility v1.1.0 Beta.

Building QtMobility was not an issue. However, when I tried to play a multimedia content in demo/player app , it just couldn't play it complaining :

no service found for - "com.nokia.qt.mediaplayer"
It was clearly a mistake of mine not having a look at the 'configure' warning messages :
Reading /home/pranaray/qt-mobility-opensource-src-1.1.0-beta2/plugins/multimedia/multimedia.pro
Project MESSAGE: QtMultiMedia checking for gstreamer...
Package gstreamer-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-0.10.pc' to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-0.10' found
Package gstreamer-base-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-base-0.10.pc' to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-base-0.10' found
Package gstreamer-interfaces-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-interfaces-0.10.pc' to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-interfaces-0.10' found
Package gstreamer-audio-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-audio-0.10.pc' to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-audio-0.10' found
Package gstreamer-video-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-video-0.10.pc' to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-video-0.10' found
The message was clearly warning about the missing gstreamer library packages.
I had to install libgstreamer0.10-dev & libgstreamer-plugins-base0.10-dev packages to resolve the issue.
sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
I also installed few additional gstreamer plugins along with the above said packages to be able to play mp3 and other media content formats.

2 comments:

Anonymous said...

Yeah that solved my problem too. Thanks for the info.

Margus Väli said...

Nice